Skip to main content

PHP-Guru gesucht

Ich brauche dringend Hilfe. Nicht wegen meines mentalen Zustandes, sondern wegen eines üblen Problems von WordPress. Sowohl nach dem Posten eines Beitrages als auch beim Kommentieren kommen merkwürdige Fehlermeldungen. Dies ist erst der Fall, seit ich das Plugin WP-Amazon installiert habe. Das sieht dann so aus:

Warning: fopen(…/years.dat) [function.fopen]: failed to open stream: Permission denied in …/af-extended-live-archive-include.php on line 723

Warning: Cannot modify header information – headers already sent by (output started at …/af-extended-live-archive/af-extended-live-archive-include.php:723) in …/pluggable-functions.php on line 272

Die Verzeichnisse habe ich gekürzt zur besseren Darstellung. Weiß irgend jemand Rat? Dann bitte melden.

4 Kommentare zu “PHP-Guru gesucht

  1. aufn ersten blick siehts aus, als wären die permissions für das file years.dat nicht richtig gesetzt (oder es ist wo, wo php nicht zugreifen darf – bei php safe mode oä.). das verursacht die erste fehlermeldung, zumindest würd ich das tippen, ohne dass ich den source selbst ansehn kann.

    die zweite fehlermeldung entsteht nur, weil eine fehlermeldung rausgeworfen wird und output erzeugt, wobei der header noch nicht fertig zusammengestöpselt ist. wenn die obere fehlermeldung (und alle anderen, falls noch mehr kommt) verschwindet, ist auch die untere weg.

  2. Hallo Olly, ganz blöde Frage von unerfahrenen Usern. Was hast Du an dem Cache-File geändert bzw. wo finde ich es. Ich habe die gleichen Probleme und weiß nicht wie ich sie lösen kann…

  3. Das Cache-File liegt im Ordner des Extended Archives. Die Dateiattribute müssen auf 777 gesetzt werden, damit das Script korrekt arbeitet. Das hat bei mir geholfen.

Kommentar verfassen